package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)USERS: ([^!]*[a-zA-Z]\d{3})![^@]+@[^ ]+ \([^) ]+\) \(\S+\) connected to the network `)
var str = `USERS: Stephanie800!Mibbit@xx.xx.xx.xx (555560E4.5124B86E.EB45475D.IP) (http://www.mibbit.com) connected to the network (our network is here)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}