# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"USERS: ([^!]*[a-zA-Z]\d{3})![^@]+@[^ ]+ \([^) ]+\) \(\S+\) connected to the network "
test_str = "USERS: Stephanie800!Mibbit@xx.xx.xx.xx (555560E4.5124B86E.EB45475D.IP) (http://www.mibbit.com) connected to the network (our network is here)"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.