$re = '/(8|[\+7]){,2}(\-|\s)?(\()?([0-9]{3})(\))?(\-|\s)?[0-9]{2}(\-|\s)?[0-9]{2}/m';
$str = '+79295002639
8 929 500 2639
+7 (929) 500 26-39
8 (929) 500 2639
8-9295002639
8478393
fkjhkhfs75768
+75836fjhgdlhg
[?:+7|8][?:\\s|\\-]\\(?[0-9]{3}\\)?[?:\\s|\\-][0-9]{3}[?:\\s|\\-][0-9]{2}[?:\\s?|\\-][0-9]{2}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);