import re
regex = re.compile(r"(8|[\+7]){,2}(\-|\s)?(\()?([0-9]{3})(\))?(\-|\s)?[0-9]{2}(\-|\s)?[0-9]{2}", flags=re.MULTILINE)
test_str = ("+79295002639\n"
"8 929 500 2639\n"
"+7 (929) 500 26-39\n"
"8 (929) 500 2639\n"
"8-9295002639\n"
"8478393\n"
"fkjhkhfs75768\n"
"+75836fjhgdlhg\n"
"[?:+7|8][?:\\s|\\-]\\(?[0-9]{3}\\)?[?:\\s|\\-][0-9]{3}[?:\\s|\\-][0-9]{2}[?:\\s?|\\-][0-9]{2}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")