#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<strong>\s*([\d.]+)\s*<small style="color:white;">"
Local $sString = "" & @CRLF & _
" <div class="row">" & @CRLF & _
" <div class="col-xs-12 col-sm-10 col-sm-offset-1 col-md-8 col-md-offset-2">" & @CRLF & _
" <div>" & @CRLF & _
" <h2 class="heading-large">" & @CRLF & _
" <strong>" & @CRLF & _
" 61312.3 <small style="color:white;">UAH</small>" & @CRLF & _
" </strong>" & @CRLF & _
" <small><span class="glyphicon glyphicon-arrow-down text-danger"></span></small> </h2>" & @CRLF & _
" <br>" & @CRLF & _
" <!--<a href="#" class="showRateDetail" style="color:#BFECFF;">Подробности конвертации <span class="caret_blue"></span></a>-->" & @CRLF & _
" <div>" & @CRLF & _
" <div class="col-xs-12" style="margin-left:0px;padding-left:0px;padding-top:10px;">" & @CRLF & _
" <table class="table table-condensed" style="opacity:0.7;">" & @CRLF & _
" <thead>" & @CRLF & _
" <tr align="left">" & @CRLF & _
" <th>Биржа</th>" & @CRLF & _
" <th>Курс</th>" & @CRLF & _
" <th>Суточный объем</th>" & @CRLF & _
" </tr>" & @CRLF & _
" </thead>" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr align="left">" & @CRLF & _
" <td><a href="/exchange/exmo/" style="color:inherit;">Exmo</a></td>" & @CRLF & _
" <td>61649.99999999</td>" & @CRLF & _
" <td>" & @CRLF & _
" <div class="progress" style="opacity:0.6;"> " & @CRLF & _
" <div class="progress-bar progress-bar-info" role="progressbar" aria-valuenow="53.68" aria-valuemin="0" aria-valuemax="100" style="width: 53.68%;">" & @CRLF & _
" <span style="color:#004F70;padding-left:5px;">17</span>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </td>" & @CRLF & _
"</tr><tr align="left">" & @CRLF & _
" <td><a href="/exchange/kuna/" style="color:inherit;">Kuna</a></td>" & @CRLF & _
" <td>60921.00000000</td>" & @CRLF & _
" <td>" & @CRLF & _
" <div class="progress" style="opacity:0.6;"> " & @CRLF & _
" <div class="progress-bar progress-bar-info" role="progressbar" aria-valuenow="46.32" aria-valuemin="0" aria-valuemax="100" style="width: 46.32%;">" & @CRLF & _
" <span style="color:#004F70;padding-left:5px;">15</span>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </td>" & @CRLF & _
"</tr> <tr align="left">" & @CRLF & _
" <td colspan="2">" & @CRLF & _
" <b>Общий объем</b>" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" <b>33 BTC</b> " & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tbody>" & @CRLF & _
" </table>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")