import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<strong>\\s*([\\d.]+)\\s*<small style=\"color:white;\">";
final String string = "\n"
+ " <div class=\"row\">\n"
+ " <div class=\"col-xs-12 col-sm-10 col-sm-offset-1 col-md-8 col-md-offset-2\">\n"
+ " <div>\n"
+ " <h2 class=\"heading-large\">\n"
+ " <strong>\n"
+ " 61312.3 <small style=\"color:white;\">UAH</small>\n"
+ " </strong>\n"
+ " <small><span class=\"glyphicon glyphicon-arrow-down text-danger\"></span></small> </h2>\n"
+ " <br>\n"
+ " <!--<a href=\"#\" class=\"showRateDetail\" style=\"color:#BFECFF;\">Подробности конвертации <span class=\"caret_blue\"></span></a>-->\n"
+ " <div>\n"
+ " <div class=\"col-xs-12\" style=\"margin-left:0px;padding-left:0px;padding-top:10px;\">\n"
+ " <table class=\"table table-condensed\" style=\"opacity:0.7;\">\n"
+ " <thead>\n"
+ " <tr align=\"left\">\n"
+ " <th>Биржа</th>\n"
+ " <th>Курс</th>\n"
+ " <th>Суточный объем</th>\n"
+ " </tr>\n"
+ " </thead>\n"
+ " <tbody>\n"
+ " <tr align=\"left\">\n"
+ " <td><a href=\"/exchange/exmo/\" style=\"color:inherit;\">Exmo</a></td>\n"
+ " <td>61649.99999999</td>\n"
+ " <td>\n"
+ " <div class=\"progress\" style=\"opacity:0.6;\"> \n"
+ " <div class=\"progress-bar progress-bar-info\" role=\"progressbar\" aria-valuenow=\"53.68\" aria-valuemin=\"0\" aria-valuemax=\"100\" style=\"width: 53.68%;\">\n"
+ " <span style=\"color:#004F70;padding-left:5px;\">17</span>\n"
+ " </div>\n"
+ " </div>\n"
+ " </td>\n"
+ "</tr><tr align=\"left\">\n"
+ " <td><a href=\"/exchange/kuna/\" style=\"color:inherit;\">Kuna</a></td>\n"
+ " <td>60921.00000000</td>\n"
+ " <td>\n"
+ " <div class=\"progress\" style=\"opacity:0.6;\"> \n"
+ " <div class=\"progress-bar progress-bar-info\" role=\"progressbar\" aria-valuenow=\"46.32\" aria-valuemin=\"0\" aria-valuemax=\"100\" style=\"width: 46.32%;\">\n"
+ " <span style=\"color:#004F70;padding-left:5px;\">15</span>\n"
+ " </div>\n"
+ " </div>\n"
+ " </td>\n"
+ "</tr> <tr align=\"left\">\n"
+ " <td colspan=\"2\">\n"
+ " <b>Общий объем</b>\n"
+ " </td>\n"
+ " <td>\n"
+ " <b>33 BTC</b> \n"
+ " </td>\n"
+ " </tr>\n"
+ " <tbody>\n"
+ " </table>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}