# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<strong>\s*([\d.]+)\s*<small style=\"color:white;\">"
test_str = ("\n"
" <div class=\"row\">\n"
" <div class=\"col-xs-12 col-sm-10 col-sm-offset-1 col-md-8 col-md-offset-2\">\n"
" <div>\n"
" <h2 class=\"heading-large\">\n"
" <strong>\n"
" 61312.3 <small style=\"color:white;\">UAH</small>\n"
" </strong>\n"
" <small><span class=\"glyphicon glyphicon-arrow-down text-danger\"></span></small> </h2>\n"
" <br>\n"
" <!--<a href=\"#\" class=\"showRateDetail\" style=\"color:#BFECFF;\">Подробности конвертации <span class=\"caret_blue\"></span></a>-->\n"
" <div>\n"
" <div class=\"col-xs-12\" style=\"margin-left:0px;padding-left:0px;padding-top:10px;\">\n"
" <table class=\"table table-condensed\" style=\"opacity:0.7;\">\n"
" <thead>\n"
" <tr align=\"left\">\n"
" <th>Биржа</th>\n"
" <th>Курс</th>\n"
" <th>Суточный объем</th>\n"
" </tr>\n"
" </thead>\n"
" <tbody>\n"
" <tr align=\"left\">\n"
" <td><a href=\"/exchange/exmo/\" style=\"color:inherit;\">Exmo</a></td>\n"
" <td>61649.99999999</td>\n"
" <td>\n"
" <div class=\"progress\" style=\"opacity:0.6;\"> \n"
" <div class=\"progress-bar progress-bar-info\" role=\"progressbar\" aria-valuenow=\"53.68\" aria-valuemin=\"0\" aria-valuemax=\"100\" style=\"width: 53.68%;\">\n"
" <span style=\"color:#004F70;padding-left:5px;\">17</span>\n"
" </div>\n"
" </div>\n"
" </td>\n"
"</tr><tr align=\"left\">\n"
" <td><a href=\"/exchange/kuna/\" style=\"color:inherit;\">Kuna</a></td>\n"
" <td>60921.00000000</td>\n"
" <td>\n"
" <div class=\"progress\" style=\"opacity:0.6;\"> \n"
" <div class=\"progress-bar progress-bar-info\" role=\"progressbar\" aria-valuenow=\"46.32\" aria-valuemin=\"0\" aria-valuemax=\"100\" style=\"width: 46.32%;\">\n"
" <span style=\"color:#004F70;padding-left:5px;\">15</span>\n"
" </div>\n"
" </div>\n"
" </td>\n"
"</tr> <tr align=\"left\">\n"
" <td colspan=\"2\">\n"
" <b>Общий объем</b>\n"
" </td>\n"
" <td>\n"
" <b>33 BTC</b> \n"
" </td>\n"
" </tr>\n"
" <tbody>\n"
" </table>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </div>\n")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.