$re = '/^(.+) - (.+) - (.+)$/m';
$str = 'Sondaggio S2 - Stresa - 15 m';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;