import re
regex = re.compile(r"^(.+) - (.+) - (.+)$", flags=re.MULTILINE)
test_str = "Sondaggio S2 - Stresa - 15 m"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)