re = /^(.+) - (.+) - (.+)$/m
str = 'Sondaggio S2 - Stresa - 15 m'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result