#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)(?:\$(?:\d+(?:\,\d+)?)|(\d+(?:-\d+)+|\d{6,}))(?!\S)"
Local $sString = "123456" & @CRLF & _
"1234567890" & @CRLF & _
"12345" & @CRLF & _
"" & @CRLF & _
"12,123" & @CRLF & _
"1-2-3" & @CRLF & _
"$1" & @CRLF & _
"$12,123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")