re = /(?<!\S)(?:\$(?:\d+(?:\,\d+)?)|(\d+(?:-\d+)+|\d{6,}))(?!\S)/m
str = '123456
1234567890
12345
12,123
1-2-3
$1
$12,123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end