$re = '/(?<!\S)(?:\$(?:\d+(?:\,\d+)?)|(\d+(?:-\d+)+|\d{6,}))(?!\S)/m';
$str = '123456
1234567890
12345
12,123
1-2-3
$1
$12,123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);