const regex = /(?:\G(?!\A),|SELECT)(?:\s+[^\s,]+(?:\([^()]*\))?,)*\s*\K[^\s,]+\s*(?:(?![()',])[[:punct:]]|AS)\s*(?:(?!FROM)[^,])*(?!\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!\\A),|SELECT)(?:\\s+[^\\s,]+(?:\\([^()]*\\))?,)*\\s*\\K[^\\s,]+\\s*(?:(?![()\',])[[:punct:]]|AS)\\s*(?:(?!FROM)[^,])*(?!\\w)', 'gm')
const str = `SELECT col, col2 AS c2, col3, col * col2 calc FROM...
SELECT name, Concat(street, ' ', city, ', ', state, ' ', zipcode) AS address
SELECT name, Concat(street, ' ', city, ', ', state, ' ', zipcode), abc AS address`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}