$re = '/(?:\G(?!\A),|SELECT)(?:\s+[^\s,]+(?:\([^()]*\))?,)*\s*\K[^\s,]+\s*(?:(?![()\',])[[:punct:]]|AS)\s*(?:(?!FROM)[^,])*(?!\w)/m';
$str = 'SELECT col, col2 AS c2, col3, col * col2 calc FROM...
SELECT name, Concat(street, \' \', city, \', \', state, \' \', zipcode) AS address
SELECT name, Concat(street, \' \', city, \', \', state, \' \', zipcode), abc AS address';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);