re = /(?:\G(?!\A),|SELECT)(?:\s+[^\s,]+(?:\([^()]*\))?,)*\s*\K[^\s,]+\s*(?:(?![()',])[[:punct:]]|AS)\s*(?:(?!FROM)[^,])*(?!\w)/m
str = 'SELECT col, col2 AS c2, col3, col * col2 calc FROM...
SELECT name, Concat(street, \' \', city, \', \', state, \' \', zipcode) AS address
SELECT name, Concat(street, \' \', city, \', \', state, \' \', zipcode), abc AS address'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end