#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=,).+(\s[A-z]{2})(\s\d.+)"
Local $sString = "2055 Niagara Falls Blvd, Amherst NY 14228" & @CRLF & _
"101 Sanford Farm Shpg Center, Amsterdam NY 12010" & @CRLF & _
"830 Curran Memorial Hwy, North Adams MA 1247"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")