const regex = /(?<=,).+(\s[A-z]{2})(\s\d.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=,).+(\\s[A-z]{2})(\\s\\d.+)', 'gm')
const str = `2055 Niagara Falls Blvd, Amherst NY 14228
101 Sanford Farm Shpg Center, Amsterdam NY 12010
830 Curran Memorial Hwy, North Adams MA 1247`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}