re = /(?<=,).+(\s[A-z]{2})(\s\d.+)/m
str = '2055 Niagara Falls Blvd, Amherst NY 14228
101 Sanford Farm Shpg Center, Amsterdam NY 12010
830 Curran Memorial Hwy, North Adams MA 1247'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end