package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\n(\|?(:? ?---.*?\|)+.*)`)
var str = `| Tables | Are | Cool |
| ------------- |:-------------:| -----:|
| col 3 is | right-aligned | $1600 |
| col 2 is | centered | $12 |
| zebra stripes | are neat | $1 |`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}