import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\n(\\|?(:? ?---.*?\\|)+.*)";
final String string = "| Tables | Are | Cool |\n"
+ "| ------------- |:-------------:| -----:|\n"
+ "| col 3 is | right-aligned | $1600 |\n"
+ "| col 2 is | centered | $12 |\n"
+ "| zebra stripes | are neat | $1 |";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}