using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\s([^\s]+)\s[0-9\-]{5,}";
string input = @"Falls Church VA 23112
Arlington Virginia 24221-2345
Arlington VIRGINIA 24221-2345
TYSON CORNER VA 232342345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}