re = /.*\s([^\s]+)\s[0-9\-]{5,}/m
str = 'Falls Church VA 23112
Arlington Virginia 24221-2345
Arlington VIRGINIA 24221-2345
TYSON CORNER VA 232342345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end