const regex = /.*\s([^\s]+)\s[0-9\-]{5,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\s([^\\s]+)\\s[0-9\\-]{5,}', 'gm')
const str = `Falls Church VA 23112
Arlington Virginia 24221-2345
Arlington VIRGINIA 24221-2345
TYSON CORNER VA 232342345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}