#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:адресу?|место(?:положение|нахождение)):?[^\n]+"
Local $sString = "...адрес: Россия Самарская область, г.Самара, ул.Ленина, 1..." & @CRLF & _
"...местоположение г.Оренбург, Ленина, д.1..." & @CRLF & _
"...адрес город Москва, Ленина, 1, кв.1..." & @CRLF & _
"...располагается по адресу: Ленинградская область, село Ленина, д.1..." & @CRLF & _
"...местонахождение: курганская Область..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")