import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:адресу?|место(?:положение|нахождение)):?[^\\n]+";
final String string = "...адрес: Россия Самарская область, г.Самара, ул.Ленина, 1...\n"
+ "...местоположение г.Оренбург, Ленина, д.1...\n"
+ "...адрес город Москва, Ленина, 1, кв.1...\n"
+ "...располагается по адресу: Ленинградская область, село Ленина, д.1...\n"
+ "...местонахождение: курганская Область...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}