import re
regex = re.compile(r"(?:адресу?|место(?:положение|нахождение)):?[^\n]+", flags=re.MULTILINE)
test_str = ("...адрес: Россия Самарская область, г.Самара, ул.Ленина, 1...\n"
"...местоположение г.Оренбург, Ленина, д.1...\n"
"...адрес город Москва, Ленина, 1, кв.1...\n"
"...располагается по адресу: Ленинградская область, село Ленина, д.1...\n"
"...местонахождение: курганская Область...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")