#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([YN]|(TRUE)|(FALSE))$"
Local $sString = "true" & @CRLF & _
"false" & @CRLF & _
"trueish" & @CRLF & _
"F" & @CRLF & _
"T" & @CRLF & _
"TRUE" & @CRLF & _
"yN" & @CRLF & _
"N" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")