$re = '/^([YN]|(TRUE)|(FALSE))$/mi';
$str = 'true
false
trueish
F
T
TRUE
yN
N
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);