package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([YN]|(TRUE)|(FALSE))$`)
var str = `true
false
trueish
F
T
TRUE
yN
N
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}