#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Benchmark.*([^EncodingJson][^JsonIter][^(GoJay(Unsafe)?]|(Decoder|Reuse|String|Unmapped|GoJson(NoEscape)?))$"
Local $sString = "Benchmark_EncodeBigData_EncodingJson" & @CRLF & _
"Benchmark_EncodeBigData_JsonIter" & @CRLF & _
"Benchmark_EncodeBigData_GoJson" & @CRLF & _
"Benchmark_MarshalBigData_EncodingJson" & @CRLF & _
"Benchmark_MarshalBigData_JsonIter" & @CRLF & _
"Benchmark_MarshalBigData_GoJson" & @CRLF & _
"Benchmark_MarshalBytes_EncodingJson" & @CRLF & _
"Benchmark_MarshalBytes_JsonIter" & @CRLF & _
"Benchmark_MarshalBytes_GoJson" & @CRLF & _
"Benchmark_EncodeRawMessage_EncodingJson" & @CRLF & _
"Benchmark_EncodeRawMessage_JsonIter" & @CRLF & _
"Benchmark_EncodeRawMessage_GoJson" & @CRLF & _
"Benchmark_MarshalString_EncodingJson" & @CRLF & _
"Benchmark_MarshalString_JsonIter" & @CRLF & _
"Benchmark_MarshalString_GoJson" & @CRLF & _
"BenchmarkCodeDecoder" & @CRLF & _
"BenchmarkUnicodeDecoder" & @CRLF & _
"BenchmarkDecoderStream" & @CRLF & _
"BenchmarkCodeUnmarshal" & @CRLF & _
"BenchmarkCodeUnmarshalReuse" & @CRLF & _
"BenchmarkUnmarshalString" & @CRLF & _
"BenchmarkUnmarshalFloat64" & @CRLF & _
"BenchmarkUnmarshalInt64" & @CRLF & _
"BenchmarkIssue10335" & @CRLF & _
"BenchmarkUnmapped" & @CRLF & _
"Benchmark_Decode_SmallStruct_Unmarshal_EncodingJson" & @CRLF & _
"Benchmark_Decode_SmallStruct_Unmarshal_JsonIter" & @CRLF & _
"Benchmark_Decode_SmallStruct_Unmarshal_GoJay" & @CRLF & _
"Benchmark_Decode_SmallStruct_Unmarshal_GoJayUnsafe" & @CRLF & _
"Benchmark_Decode_SmallStruct_Unmarshal_GoJson" & @CRLF & _
"Benchmark_Decode_SmallStruct_Unmarshal_GoJsonNoEscape" & @CRLF & _
"Benchmark_Decode_SmallStruct_Stream_EncodingJson" & @CRLF & _
"Benchmark_Decode_SmallStruct_Stream_JsonIter" & @CRLF & _
"Benchmark_Decode_SmallStruct_Stream_GoJay" & @CRLF & _
"Benchmark_Decode_SmallStruct_Stream_GoJson" & @CRLF & _
"Benchmark_Decode_MediumStruct_Unmarshal_EncodingJson" & @CRLF & _
"Benchmark_Decode_MediumStruct_Unmarshal_JsonIter" & @CRLF & _
"Benchmark_Decode_MediumStruct_Unmarshal_GoJay" & @CRLF & _
"Benchmark_Decode_MediumStruct_Unmarshal_GoJayUnsafe" & @CRLF & _
"Benchmark_Decode_MediumStruct_Unmarshal_GoJson" & @CRLF & _
"Benchmark_Decode_MediumStruct_Unmarshal_GoJsonNoEscape" & @CRLF & _
"Benchmark_Decode_MediumStruct_Stream_EncodingJson" & @CRLF & _
"Benchmark_Decode_MediumStruct_Stream_JsonIter" & @CRLF & _
"Benchmark_Decode_MediumStruct_Stream_GoJay" & @CRLF & _
"Benchmark_Decode_MediumStruct_Stream_GoJson" & @CRLF & _
"Benchmark_Decode_LargeStruct_Unmarshal_EncodingJson" & @CRLF & _
"Benchmark_Decode_LargeStruct_Unmarshal_JsonIter" & @CRLF & _
"Benchmark_Decode_LargeStruct_Unmarshal_GoJay" & @CRLF & _
"Benchmark_Decode_LargeStruct_Unmarshal_GoJayUnsafe" & @CRLF & _
"Benchmark_Decode_LargeStruct_Unmarshal_GoJson" & @CRLF & _
"Benchmark_Decode_LargeStruct_Unmarshal_GoJsonNoEscape" & @CRLF & _
"Benchmark_Decode_LargeStruct_Stream_EncodingJson" & @CRLF & _
"Benchmark_Decode_LargeStruct_Stream_JsonIter" & @CRLF & _
"Benchmark_Decode_LargeStruct_Stream_GoJay" & @CRLF & _
"Benchmark_Decode_LargeStruct_Stream_GoJson" & @CRLF & _
"Benchmark_Encode_SmallStruct_EncodingJson" & @CRLF & _
"Benchmark_Encode_SmallStruct_JsonIter" & @CRLF & _
"Benchmark_Encode_SmallStruct_GoJay" & @CRLF & _
"Benchmark_Encode_SmallStruct_GoJson" & @CRLF & _
"Benchmark_Encode_MediumStruct_EncodingJson" & @CRLF & _
"Benchmark_Encode_MediumStruct_JsonIter" & @CRLF & _
"Benchmark_Encode_MediumStruct_GoJay" & @CRLF & _
"Benchmark_Encode_MediumStruct_GoJson" & @CRLF & _
"Benchmark_Encode_LargeStruct_EncodingJson" & @CRLF & _
"Benchmark_Encode_LargeStruct_JsonIter" & @CRLF & _
"Benchmark_Encode_LargeStruct_GoJay" & @CRLF & _
"Benchmark_Encode_LargeStruct_GoJson"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")