const regex = new RegExp('^Benchmark.*([^EncodingJson][^JsonIter][^(GoJay(Unsafe)?]|(Decoder|Reuse|String|Unmapped|GoJson(NoEscape)?))$', 'mg')
const str = `Benchmark_EncodeBigData_EncodingJson
Benchmark_EncodeBigData_JsonIter
Benchmark_EncodeBigData_GoJson
Benchmark_MarshalBigData_EncodingJson
Benchmark_MarshalBigData_JsonIter
Benchmark_MarshalBigData_GoJson
Benchmark_MarshalBytes_EncodingJson
Benchmark_MarshalBytes_JsonIter
Benchmark_MarshalBytes_GoJson
Benchmark_EncodeRawMessage_EncodingJson
Benchmark_EncodeRawMessage_JsonIter
Benchmark_EncodeRawMessage_GoJson
Benchmark_MarshalString_EncodingJson
Benchmark_MarshalString_JsonIter
Benchmark_MarshalString_GoJson
BenchmarkCodeDecoder
BenchmarkUnicodeDecoder
BenchmarkDecoderStream
BenchmarkCodeUnmarshal
BenchmarkCodeUnmarshalReuse
BenchmarkUnmarshalString
BenchmarkUnmarshalFloat64
BenchmarkUnmarshalInt64
BenchmarkIssue10335
BenchmarkUnmapped
Benchmark_Decode_SmallStruct_Unmarshal_EncodingJson
Benchmark_Decode_SmallStruct_Unmarshal_JsonIter
Benchmark_Decode_SmallStruct_Unmarshal_GoJay
Benchmark_Decode_SmallStruct_Unmarshal_GoJayUnsafe
Benchmark_Decode_SmallStruct_Unmarshal_GoJson
Benchmark_Decode_SmallStruct_Unmarshal_GoJsonNoEscape
Benchmark_Decode_SmallStruct_Stream_EncodingJson
Benchmark_Decode_SmallStruct_Stream_JsonIter
Benchmark_Decode_SmallStruct_Stream_GoJay
Benchmark_Decode_SmallStruct_Stream_GoJson
Benchmark_Decode_MediumStruct_Unmarshal_EncodingJson
Benchmark_Decode_MediumStruct_Unmarshal_JsonIter
Benchmark_Decode_MediumStruct_Unmarshal_GoJay
Benchmark_Decode_MediumStruct_Unmarshal_GoJayUnsafe
Benchmark_Decode_MediumStruct_Unmarshal_GoJson
Benchmark_Decode_MediumStruct_Unmarshal_GoJsonNoEscape
Benchmark_Decode_MediumStruct_Stream_EncodingJson
Benchmark_Decode_MediumStruct_Stream_JsonIter
Benchmark_Decode_MediumStruct_Stream_GoJay
Benchmark_Decode_MediumStruct_Stream_GoJson
Benchmark_Decode_LargeStruct_Unmarshal_EncodingJson
Benchmark_Decode_LargeStruct_Unmarshal_JsonIter
Benchmark_Decode_LargeStruct_Unmarshal_GoJay
Benchmark_Decode_LargeStruct_Unmarshal_GoJayUnsafe
Benchmark_Decode_LargeStruct_Unmarshal_GoJson
Benchmark_Decode_LargeStruct_Unmarshal_GoJsonNoEscape
Benchmark_Decode_LargeStruct_Stream_EncodingJson
Benchmark_Decode_LargeStruct_Stream_JsonIter
Benchmark_Decode_LargeStruct_Stream_GoJay
Benchmark_Decode_LargeStruct_Stream_GoJson
Benchmark_Encode_SmallStruct_EncodingJson
Benchmark_Encode_SmallStruct_JsonIter
Benchmark_Encode_SmallStruct_GoJay
Benchmark_Encode_SmallStruct_GoJson
Benchmark_Encode_MediumStruct_EncodingJson
Benchmark_Encode_MediumStruct_JsonIter
Benchmark_Encode_MediumStruct_GoJay
Benchmark_Encode_MediumStruct_GoJson
Benchmark_Encode_LargeStruct_EncodingJson
Benchmark_Encode_LargeStruct_JsonIter
Benchmark_Encode_LargeStruct_GoJay
Benchmark_Encode_LargeStruct_GoJson`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}