# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^Benchmark.*([^EncodingJson][^JsonIter][^(GoJay(Unsafe)?]|(Decoder|Reuse|String|Unmapped|GoJson(NoEscape)?))$"
test_str = ("Benchmark_EncodeBigData_EncodingJson\n"
"Benchmark_EncodeBigData_JsonIter\n"
"Benchmark_EncodeBigData_GoJson\n"
"Benchmark_MarshalBigData_EncodingJson\n"
"Benchmark_MarshalBigData_JsonIter\n"
"Benchmark_MarshalBigData_GoJson\n"
"Benchmark_MarshalBytes_EncodingJson\n"
"Benchmark_MarshalBytes_JsonIter\n"
"Benchmark_MarshalBytes_GoJson\n"
"Benchmark_EncodeRawMessage_EncodingJson\n"
"Benchmark_EncodeRawMessage_JsonIter\n"
"Benchmark_EncodeRawMessage_GoJson\n"
"Benchmark_MarshalString_EncodingJson\n"
"Benchmark_MarshalString_JsonIter\n"
"Benchmark_MarshalString_GoJson\n"
"BenchmarkCodeDecoder\n"
"BenchmarkUnicodeDecoder\n"
"BenchmarkDecoderStream\n"
"BenchmarkCodeUnmarshal\n"
"BenchmarkCodeUnmarshalReuse\n"
"BenchmarkUnmarshalString\n"
"BenchmarkUnmarshalFloat64\n"
"BenchmarkUnmarshalInt64\n"
"BenchmarkIssue10335\n"
"BenchmarkUnmapped\n"
"Benchmark_Decode_SmallStruct_Unmarshal_EncodingJson\n"
"Benchmark_Decode_SmallStruct_Unmarshal_JsonIter\n"
"Benchmark_Decode_SmallStruct_Unmarshal_GoJay\n"
"Benchmark_Decode_SmallStruct_Unmarshal_GoJayUnsafe\n"
"Benchmark_Decode_SmallStruct_Unmarshal_GoJson\n"
"Benchmark_Decode_SmallStruct_Unmarshal_GoJsonNoEscape\n"
"Benchmark_Decode_SmallStruct_Stream_EncodingJson\n"
"Benchmark_Decode_SmallStruct_Stream_JsonIter\n"
"Benchmark_Decode_SmallStruct_Stream_GoJay\n"
"Benchmark_Decode_SmallStruct_Stream_GoJson\n"
"Benchmark_Decode_MediumStruct_Unmarshal_EncodingJson\n"
"Benchmark_Decode_MediumStruct_Unmarshal_JsonIter\n"
"Benchmark_Decode_MediumStruct_Unmarshal_GoJay\n"
"Benchmark_Decode_MediumStruct_Unmarshal_GoJayUnsafe\n"
"Benchmark_Decode_MediumStruct_Unmarshal_GoJson\n"
"Benchmark_Decode_MediumStruct_Unmarshal_GoJsonNoEscape\n"
"Benchmark_Decode_MediumStruct_Stream_EncodingJson\n"
"Benchmark_Decode_MediumStruct_Stream_JsonIter\n"
"Benchmark_Decode_MediumStruct_Stream_GoJay\n"
"Benchmark_Decode_MediumStruct_Stream_GoJson\n"
"Benchmark_Decode_LargeStruct_Unmarshal_EncodingJson\n"
"Benchmark_Decode_LargeStruct_Unmarshal_JsonIter\n"
"Benchmark_Decode_LargeStruct_Unmarshal_GoJay\n"
"Benchmark_Decode_LargeStruct_Unmarshal_GoJayUnsafe\n"
"Benchmark_Decode_LargeStruct_Unmarshal_GoJson\n"
"Benchmark_Decode_LargeStruct_Unmarshal_GoJsonNoEscape\n"
"Benchmark_Decode_LargeStruct_Stream_EncodingJson\n"
"Benchmark_Decode_LargeStruct_Stream_JsonIter\n"
"Benchmark_Decode_LargeStruct_Stream_GoJay\n"
"Benchmark_Decode_LargeStruct_Stream_GoJson\n"
"Benchmark_Encode_SmallStruct_EncodingJson\n"
"Benchmark_Encode_SmallStruct_JsonIter\n"
"Benchmark_Encode_SmallStruct_GoJay\n"
"Benchmark_Encode_SmallStruct_GoJson\n"
"Benchmark_Encode_MediumStruct_EncodingJson\n"
"Benchmark_Encode_MediumStruct_JsonIter\n"
"Benchmark_Encode_MediumStruct_GoJay\n"
"Benchmark_Encode_MediumStruct_GoJson\n"
"Benchmark_Encode_LargeStruct_EncodingJson\n"
"Benchmark_Encode_LargeStruct_JsonIter\n"
"Benchmark_Encode_LargeStruct_GoJay\n"
"Benchmark_Encode_LargeStruct_GoJson")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.