import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S+=(\\([^(]*(?:[^(\"]*\"[^\"]*\")(\\)))";
final String string = "start=(\"a\", \"b\") and between=(\"range(2019, max, to=\\\"le\\\")\") and end=(\"a\", \"b\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}