re = /\S+=(\([^(]*(?:[^("]*"[^"]*")(\)))/m
str = 'start=("a", "b") and between=("range(2019, max, to=\\"le\\")") and end=("a", "b")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end