$re = '`\S+=(\([^(]*(?:[^("]*"[^"]*")(\)))`m';
$str = 'start=("a", "b") and between=("range(2019, max, to=\\"le\\")") and end=("a", "b")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);