#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([.#0-9a-zA-Z]+\.)(\S*)\s+([0-9]+)"
Local $sString = "vib.h.p.f2.synt 4 " & @CRLF & _
"vib.h.p.g#2.synt 7" & @CRLF & _
"vib.h.p.a#3.synt 8"
Local $sSubst = "$1$3.$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)