import Foundation
let pattern = ##"([.#0-9a-zA-Z]+\.)(\S*)\s+([0-9]+)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
vib.h.p.f2.synt 4
vib.h.p.g#2.synt 7
vib.h.p.a#3.synt 8
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3.$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)