$re = '/([.#0-9a-zA-Z]+\.)(\S*)\s+([0-9]+)/m';
$str = 'vib.h.p.f2.synt 4
vib.h.p.g#2.synt 7
vib.h.p.a#3.synt 8';
$subst = "$1$3.$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;