#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)({width.+in})"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"jkhdkjfhgkjsdfhk" & @CRLF & _
"" & @CRLF & _
"fdskjglkdfs" & @CRLF & _
"{width=kfdjslkgjdflks" & @CRLF & _
"dfgdf" & @CRLF & _
"in}" & @CRLF & _
"" & @CRLF & _
"sdfkjglkdflgkds"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")