package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)({width.+in})`)
var str = `
jkhdkjfhgkjsdfhk
fdskjglkdfs
{width=kfdjslkgjdflks
dfgdf
in}
sdfkjglkdflgkds`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}