using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?! |.* $)(?=.*[a-zA-Z])[a-zA-Z0-9""',\ \-]+$";
string input = @"a
a
a
abc123
abc-123
-
1
""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}