re = /^(?! |.* $)(?=.*[a-zA-Z])[a-zA-Z0-9"',\ \-]+$/m
str = 'a
a
a
abc123
abc-123
-
1
"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end