$re = '/^(?! |.* $)(?=.*[a-zA-Z])[a-zA-Z0-9"\',\ \-]+$/m';
$str = 'a
a
a
abc123
abc-123
-
1
"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);