use strict;
my $str = 'roman MCMLXXXVIII. roman XVII notroman MADXXXL invalid MILLI';
my $regex = qr/\b(?=[MDCLXVIΙ])M{0,4}(CM|CD|D?C{0,3})(XC|XL|L?X{0,3})([IΙ]X|[IΙ]V|V?[IΙ]{0,3})\b\.?/mp;
my $subst = '&';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";