import Foundation
let pattern = #"\b(?=[MDCLXVIΙ])M{0,4}(CM|CD|D?C{0,3})(XC|XL|L?X{0,3})([IΙ]X|[IΙ]V|V?[IΙ]{0,3})\b\.?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"roman MCMLXXXVIII. roman XVII notroman MADXXXL invalid MILLI"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"&"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)