$re = '/\b(?=[MDCLXVIΙ])M{0,4}(CM|CD|D?C{0,3})(XC|XL|L?X{0,3})([IΙ]X|[IΙ]V|V?[IΙ]{0,3})\b\.?/m';
$str = 'roman MCMLXXXVIII. roman XVII notroman MADXXXL invalid MILLI';
$subst = "&";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;