$re = '/"MachineSID" *: *"([\d-]+?)"/';
$str = '{ "ConfigName" : "SiteName", "Name" : "ABCTest" } "Windows" : { "MachineSID" : "15371-868-9808907-15424" }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);