re = /"MachineSID" *: *"([\d-]+?)"/
str = '{ "ConfigName" : "SiteName", "Name" : "ABCTest" } "Windows" : { "MachineSID" : "15371-868-9808907-15424" }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end