// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""MachineSID" *: *"([\d-]+?)""#).unwrap();
let string = "{ \"ConfigName\" : \"SiteName\", \"Name\" : \"ABCTest\" } \"Windows\" : { \"MachineSID\" : \"15371-868-9808907-15424\" }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}